电脑互动吧

 找回密码
 注册
查看: 8301|回复: 0

IIS运行过程中遇到的问题及解决方法

[复制链接]
发表于 2011-7-22 00:53:31 | 显示全部楼层 |阅读模式
一般来讲,如果一切顺利的话,IIS就可以成功运行了。但实践中由于现在操作系统版本的复杂性,会出现很多问题。9 Q! r$ I# y* O( g, m5 p
故障0 :mmc管理单元无法打开,那就是说安装没有成功。 因为xp版本对应的IIS是5.1,而如果我们安装了5.0或者6.0版本的话,是无论如何也无法成功的。: l" h* ]  d% A- e% r  Z8 o! ?
解决:安装之前最好先找对应该安装的版本。
$ B- T! M" C& G7 g故障1:winxp系统的IIS默认网站无法启动。手动启动时报“服务没有及时响应启动或控制请求”,再进一步检查,“World Wide Web Publishing服务“不能启动所至,该服务手动启动时报错为“错误号127,找不到指定的程序”,程序当然是存在的,删除IIS重装还是不行。1 V+ Y0 v; v' m! {! s, l
原因:系统服务没有启动,因为GHOST版XP可能停用了一些服务,导致World Wide Web Publishing服务不能启动。: f1 ~7 f4 o  X1 c2 _/ Q8 [7 D0 X7 E" P8 E
解决:只要按照他的依存关系,把其他的服务启动了就可以了,它依存关系的启动的是IIS Admin Service。
) x: \2 i3 {# @) L$ B注意:还有一种情况可能是IIS版本不兼容。GHOST的WINDOWS有SP2和SP3之分,在排除以上系统服务的故障后,有时会发现仍然是启动不了。后来我发现了IIS5.1 XP和IIS5.1 XPSP3两个版本,我的操作系统是WINDOWS SP3,开始随便下了一个IIS5.1 XP安装包,结果无法启动World Wide Web Publishing服务。
/ S; ^- n. v# Q( v解决:下了一个IIS5.1 XP SP3安装包重新安装,一切正常。. S( \( M  W5 x2 K) w* U# ?
故障2:winxp系统的IIS默认网站无法启动。手动启动时报“服务没有及时响应启动或控制请求”,但是“World Wide Web Publishing服务”已经正常启动。" U* t. Y6 m0 E5 X4 ~- U& i
原因:系统漏洞补丁导致,关于系统漏洞补丁的资料网上很多,都是那几个补丁删除即可,但都很杂,我细细分析了一下,发现不同的操作系统版本删除的补丁不一样了。5 }5 x) z/ L- g3 N
补丁KB9397379:在微软的官方资料上是这样描述:此重要安全更新可解决一个秘密报告的漏洞。 如果攻击者向 Windows XP Professional Service Pack 2 上 Internet Information Services (IIS) 5.1 宿主的网页发送特制的 URL 请求,则此漏洞可能允许远程执行代码。IIS 5.1 不是 Windows XP Professional Service Pack 2 默认安装的一部分。成功利用此漏洞的攻击者可以完全控制受影响的系统。可以看得出这是针对WINXP SP2的操作系统。1 T# ?$ ~- m6 X/ j  X
补丁KB2124261和KB2290570:在微软的官方资料上描述主要是针对winxp sp3,win2003,win2008,win7操作系统。* Y) {( g9 _  r9 V  i1 G6 Y1 T
解决:根据自己的操作系统版本卸掉相应的补丁就可以了。在网上经常碰到有些用户埋怨没有找到相应的补丁,原因就是他没有根据自己的系统版本有针对性的找了。
8 S5 g% Z3 |/ D% l: D& T+ e4 D故障3:同样是 World Wide Web Publishing服务不能启动所至,但服务报错为“错误号1717 未知的接口“3 v8 K5 E# i. B$ t+ G% Y
原因:没有启动Event Log服务,尽管这不是World Wide Web Publishing所依赖的服务。
# \/ a3 Z# F: |8 H6 \解决:,启动Event Log服务即可。% I; {3 ^/ [' a# E6 R# l( `' u/ ]! F( a
故障4:手动启动时报“服务没有及时响应启动或控制请求” ,但是 World Wide Web Publishing服务已正常启动,漏洞补丁问题也排除。! b( \9 P8 ~! ~  J
原因: IIS默认的80端口被占用了。$ g6 I6 [  N  v; U+ Y* W( d! k$ k
方法一:使用DOS命令找到占用80端口的程序,关闭该程序
: j' h6 P& p# l, T在开始——运行中输入以下命令:& |# ]  Z( U% a+ ^) j" ]5 }
1、netstat -an -p tcp –o
1 s4 ?6 H& T2 W* z4 |2 j) U' B3 T     在Local Adress 中找到80端口,在PID中找到使用80端口的服务)
! b( u" U" f) X- l2、tskill 1182 (1182即占用查找到的占用80端口的PID程序)     " M  X6 c6 U! z' C8 o* ~6 Y( p
     使用tskill命令关闭该程序;注意:这里的PID1182是举例,根据你的实际情况,哪个程序占用了80端口,则关闭哪个程序的PID" g  L% G5 T5 K
3、命令iisreset/restart重启IIS( 或者手动重启IIS服务): g% q1 b* p% }6 v; Q/ D2 r
方法二:把IIS的80端口改为其它为被使用的端口,如80改为8080,同时改站点的端口为8080。
, U) u- N! n! D6 A9 A  g1、改IIS的80端口改为未被使用的端口,随意取值,未被使用就性,在这里改成8080端口。$ i3 h' ?$ l8 b+ ~
2、重启IIS。这时IIS已经可以启动,已经可以在IIS里浏览文件。
( X& y+ b' ?4 V7 u* `' q9 l3、对应的在站点中把站点的端口改为IIS现在的8080端口,如由原来的http://localhost/改成http: //localhost:8080/ 。如果不改站点端口,则每次访问站点时都需要输入端口,如要访问index.asp,就要输入:http://localhost:8080/ index.asp。  m! S) ?& q, t% v1 s1 z
否则无法访问网页,提示找不到服务器或 DNS 错误。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

联系我们|手机版|小黑屋|Archiver|电脑互动吧 ( 浙ICP备13037409号 )

浙公网安备 33032402001025号

GMT+8, 2026-9-21 18:46 , Processed in 0.052757 second(s), 18 queries .

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表